00-Intro

O StrongRecovery
Do przodu

StrongRecovery jest aplikacją przeznaczoną do odzyskiwania skasowanych lub utraconych danych (pliki, zdjęcia) oraz partycji (również dysków logicznych) z nośników takich jak: pendrive, karta pamięci czy twardy dysk. Jest szybkie i łatwe w użyciu. StrongRecovery jest kompatybilne z wszystkimi nowymi systemami Microsoft Windows®: Windows 7, Vista, XP, 2003, 200 0.

DETEKCJA I ODZYSKIWANIE PARTYCJI:

  • Wspierane systemy plików : NTFS, FAT12, FAT16, FAT32, EXFAT, EXT2, EXT3, HPFS, REISERFS, LINUX SWAP
  • Detekcja rekordów rozruchowych (boot records) poprzez skanowanie dysku fizycznego
  • Naprawianie informacji nagłówkowych partycji/dysku (tablica partycji, rekord rozruchowy, blok EPP).

SYSTEMY PLIKÓW (EKSPLORACJA):

  • Wspierane systemy plików : NTFS, FAT12, FAT16, FAT32, EXFAT, RAW (binaria)
  • Wsparte odzyskiwanie zaszyfrowanych plików NTFS (EFS) i skompresowanych plików NTFS
  • Dostępne formaty w silniku RAW : BMP, JPG, JP2, GIF, PNG, TGA, PCX, TIF, TXT (ASCII and UNICODE text data) , MP3, WAV, AVI, DAT, SWF, PDF, DOC, PPT, XLS, DOCX, PPTX, XLSX, ZIP, RAR, EXE, DLL, ICL, PSD, MKV, ISO, 7Z, ACE, 3GP, MPG/VOB, DDS, CHM, EML, DBX, PST.

ZAAWANSOWANE OPCJE :

  • Obliczanie rozmiaru plików RAW (rozmiar pliku RAW jest obliczany poprzez analizę informacji nagłówkowych)
  • Przywracanie nazw plikom RAW - StrongRecovery potrafi nadać trafną nazwę plikom RAW, dla przykładu: nazywanie MP3 (czytanie tagów)
  • Naprawa danych alokacji FAT32 (technika ta pozwala na lokalizację pierwszego klastra pliku ze skasowanym wpisem, niektóre wpisy alokacji FAT32 są zamazywane po usunięciu pliku, StrongRecovery może naprawić ten problem)
  • Eksploracja obecnych (nieskasowanych) plików jest możliwa. Jeśli potrzebujesz zrzucić uszkodzony bądź zabezpieczony plik systemowy, możesz to zrobić za pośrednictwem przeglądarki StrongRecovery
  • Możliwość przeszukiwania danych (wewnątrz plików również)
  • Opcja edycji rozmiaru pliku - pozwala na nadanie rozmiaru ręcznie.

CECHY PRZEGLĄDARKI :

  • Wyświetlanie miniaturek obrazków
  • Dynamiczne skanowanie danych (eksploracja danych jest możliwa podczas trwającego skanowania)
  • Sesje skanowania (możesz zapisać obecny stan skanowania i odtworzyć go kiedy indziej)
  • Filtrowanie treści plików (wyświetlanie plików, które Ciebie interesują, w zależności od ich kondycji lub rodzaju)
  • Przyjazny interfejs użytkownika.

Jakiekolwiek błędy (bugi), sugestie, pytania oraz komentarze na temat oprogramowania proszę kierować na adres: support@strongrecovery.com.

Copyright © 2012 - 2022 Maciej Drobiński
http://www.strongrecovery.com

Do przodu


01-Requirements

Wymagania StrongRecovery
  • System Microsoft Windows® 2000/XP/2003/Vista/Windows 7
  • Dysk z przynajmniej 2 MB wolnej przestrzeni
  • Dostępne pliki źródłowe StrongRecovery:
    • Setup (wymaga instalacji)
    • Przenośny
    • Zip (archiwum z plikami oprogramowania)


02-License

Licencja

Używanie, dystrybucja lub instalacja oprogramowania StrongRecovery wymaga akceptacji warunków tej licencji. Jeśli nie zgadzasz się z jakimiś postanowieniami, nie instaluj, nie rozpowszechniaj ani nie używaj tego oprogramowania.

Wersja demonstracyjna może być używana tylko i wyłącznie do celów zapoznawczych. Kupno licencji osobistej (personal license) uprawnia Ciebie do instalacji jednej kopii pełnej wersji oprogramowania na jednym komputerze. Licencja siedliskowa (site license) uprawnia Cię do instalacji kilku kopii na stacjach roboczych w firmie lub organizacji. Licencja komercyjna (commercial license) daje Ci prawa do zysków czerpanych z odzyskiwania danych za pośrednictwem oprogramowania StrongRecovery.

Oprogramowanie to, wszelkie powiązane z nim pliki są rozpowszechniane w takiej formie "jaka ona jest" i bez jakichkolwiek gwarancji wyraźnych ani dorozumianych, w maksymalnym zakresie dozwolonym przez obowiązujące prawo.

Nie wolno pożyczać, wydzierżawiać, modyfikować, tłumaczyć, stosować inżynierii wstecznej, dekompilować/demontować oprogramowania lub tworzyć dzieł pochodnych na jego podstawie, bez uprzedniej wyraźnej zgody. Wszelkie prawa jakiegokolwiek rodzaju do tego oprogramowania, które nie są wyraźnie przyznane w niniejszej umowie licencyjnej są całkowicie i wyłącznie zastrzeżone przez autora, którym jest Maciej Drobiński.

Copyright © 2012 - 2022 Maciej Drobinski


11-SelectDriveWindow

Okno wyboru dysku

Okno wyboru dysku pozwala wybrać Ci dysk do eksploracji i odzyskiwania danych. Możesz również określić parametry dysku (system plików) aby odzyskać dane z dysku uprzednio sformatowanego w innym systemie plików (okno zaawansowanych opcji dysku).

Opcja "Otwórz->sesja" pozwala na wgranie sesji skanowania zapisanej podczas skanowania/eksploracji (sesje StrongRecovery są zapisywane w oknie przeglądarki oraz w oknie skanowania dysku fizycznego).

PRZYCISK | OPIS
Odśwież | Odśwież listę dysków
Ustawienia | Zaawansowane opcje dysku
Otwórz | Wczytaj obraz, kopię zapasową, sesję
Dalej | Otwórz wybrany dysk
Wyjście | Zamknij aplikację


112-PartitionFixWindow

Okno szybkiego przywracania partycji

Okno szybkiego przywracania partycji umożliwia dostęp do utraconych partycji/dysków oraz ich naprawę. Jeśli okno te się pokazuje, oznacza to, że są niezgodne bądź uszkodzone informacje w rekordach rozruchowych, tablicy partycji. Dyski są przez to prawdopodobnie niewidoczne i niedostępne, możesz naprawić ten problem poprzez kliknięcie na przycisk "Przywróć". Aby zobaczyć jakie struktury wymagają naprawy, kliknij na "Szczegóły". Przed przystąpieniem do naprawy, zaleca się utworzenie kopii zapasowej (Przycisk "Zrób backup"). Ze względów bezpieczeństwa, po dokonaniu zmian naprawczych, kopia zapasowa zostaje utworzona automatycznie (katalog z oprogramowaniem i zawartość katalogu "auto-backups"). Kopię taką można wczytać poprzez okno wyboru dysku (przycisk "Otwórz").

PRZYCISK | OPIS
Zrób backup | Utwórz kopię zapasową zmienianych danych
Przywróć | Przeprowadź naprawę uszkodzonych struktur dyskowych celem przywrócenia partycji/dysków
Szczegóły | Szczegóły procesu naprawiania
Zamknij | Zamknij okno


113-FixDetailsWindow

Okno szczegółów naprawiania

Okno szczegółów naprawy pozwala na wybór zadań naprawy struktur w uszkodzonych partycjach/dyskach lub w MBR (Master Boot Record). Możesz zdecydować jakiego rodzaju naprawa ma być przeprowadzona.

PRZYCISK | OPIS
Ok | Akceptuj zmiany
Anuluj | Wróć do poprzednich ustawień


12-DriveSettingsWindow

Okno zaawansowanych ustawień dysku

OPCJA | OPIS
System plików jest nienaruszony | Strongrecovery rozpocznie odzyskiwanie na podstawie bieżącego systemu
Poprzednio był inny system | StrongRecovery rozpocznie odzyskiwanie biorąc pod uwagę inny system plików, ustalony przez użytkownika
System plików jest uszkodzony | StrongRecovery rozpocznie odzyskiwanie nie ingerując w system plików (MFT/FAT) poprzez analizę RAW


121-PhysicalDriveScanWindow

Okno wyboru trybu skanowania dysku fizycznego

OPCJA | OPIS
Szukanie i odzyskiwanie partycji (DEEP DETECT) | Szukaj nadpisane bądź niewidoczne partycje sektor po sektorze
Szukanie i odzyskiwanie partycji (FAST DETECT) | Szybkie szukanie partycji z pomijaniem integralnych danych
Skanowanie w poszukiwaniu plików (RAW) | Odzyskaj pliki poprzez detekcję ich nagłówków skanując od początku do końca dysku
Wsteczne skanowanie w poszukiwaniu plików | Odzyskaj pliki poprzez detekcję ich nagłówków skanując od końca do początku dysku (zastosowanie przy problemach z odczytem z dysku)
Pozycja startow | Ustal pozycję startową skanowania


122-PhysicalDriveScanWindow

Okno skanowania dysku fizycznego (poszukiwanie partycji)

OPCJA | OPIS
Zapisz | Zapisz bieżący stan skanowania (plik sesji może być wgrany poprzez okno wyboru dysku)
Pauza/Wznów | Zatrzymaj lub wznów skanowanie
Dalej | Idź do wyników wyszukiwania (lista partycji/dysków)
Zamknij | Zakończ skanowanie, zamknij okno


123-PhysicalDriveScanResultsWindow

Okno wyników skanowania dysku fizycznego

OPCJA | OPIS
Cofnij | Wróć do skanowania dysku fizycznego (kontynuuj poszukiwania)
Ustawienia | Ustawienia dysku (okno zaawansowanych ustawień dysku)
Dalej | Otwórz dysk (eksploruj go)


13-ExploreWindow

Okno przeglądarki

Okno eksplorera StrongRecovery jest klasycznym interfejsem przeglądarki. Jest proste w użyciu, a jego obsługa jest intuicyjna (podobnie jak w systemie). Kiedy znajdziesz pliki do odzyskania, wybierz je (zaznacz) i uruchom opcje odzyskiwania (menu główne -> Plik -> Odzyskaj... lub menu podręczne -> Odzyskaj...) aby odzyskać skasowane/stracone pliki.

Menu główne

OPCJA/PODMENU | SKRÓT | OPIS
PLIK | - | -
Odzyskaj | Alt+R | Rozpocznij odzyskiwanie zaznaczonych plików
Zapisz plik sesji | Ctrl+L | Zapisz plik sesji (obecny stan skanowania)
Zamknij | Esc | Zamknij przeglądarkę
EDYCJA | - | -
Wybierz wszystko | Ctrl+A | Wybierz wszystkie pliki na liście
Odznacz wszystko | Ctrl+Z | Odznacz wszystkie pliki na liście
Odwróć zaznaczenie | Ctrl+I | Odwróć zaznaczenie plików
WIDOK | - | -
Tryb przeglądarki | - | Zmień tryb wyświetlania na miniaturki lub szczegóły
Drzewo katalogów | - | Pokaż/ukryj drzewo katalogów
Filtrowanie | - | Pokaż/ukryj okno filtrowania
POLECENIA | - | -
Zatrzymaj skanowanie | - | Zatrzymaj skanowanie wolnego obszaru
Przerwij wyszukiwanie | - | Przerwij wyszukiwanie plików/danych
USTAWIENIA | - | -
Konfiguracja folderów | - | Ustaw Foldery StrongRecovery
ULUBIONE | - | -
Dodaj bieżącą ścieżkę | Ctrl+D | Dodaj aktualnie przeglądaną ścieżkę do listy ulubionych
POMOC | - | -
Zawartość | F1 | Uruchom plik pomocy
Pomoc online | - | Przeglądaj pomoc online
O programie | - | Pokaż informacje o programie

Menu podręczne listy plików

OPCJA | SKRÓT | OPIS
Odzyskaj | Alt+R | Rozpocznij odzyskiwanie zaznaczonych plików
Edytuj rozmiar pliku | Alt+X | Ustaw zwirtualizowany rozmiar pliku
Widok | - | Zmień tryb wyświetlania (miniaturki lub szczegóły)
Odśwież | F5 | Odśwież listę plików
Select | Spacja | Wybierz plik pod kursorem
Wybierz wszystko | Ctrl+A | Wybierz wszystkie pliki na liście
Odznacz wszystko | Ctrl+Z | Odznacz wszystkie pliki na liście
Odwróć zaznaczenie | Ctrl+I | Odwróć zaznaczenie plików
Właściwości | Alt+Enter | Wyświetl właściwości pliku

Menu podręczne drzewa katalogowego

OPCJA | SKRÓT | OPIS
Odzyskaj | Alt+R | Rozpocznij odzyskiwanie zaznaczonych plików
Właściwości | Alt+Enter | Wyświetl właściwości pliku (folderu)


14-DisplayFilesWindow

Okno filtrowania plików (wyświetlanie)

OPCJA/GRUPA | OPIS
Pliki | Wyświetlaj pliki
Foldery | Wyświetlaj foldery
MASKI PLIKÓW | -
Każdy plik | Wyświetlaj każdy plik (wszystkie maski)
Grafika | Wyświetlaj pliki graficzne (z predefiniowanymi maskami graficznymi)
Audio | Wyświetlaj pliki audio (z predefiniowanymi maskami audio)
Video | Wyświetlaj pliki video (z predefiniowanymi maskami video)
Office/biuro | Wyświetlaj pliki biurowe (z predefiniowanymi maskami biurowymi)
System | Wyświetlaj pliki wykonywalne, dll
TYP PLIKÓW | -
Odzyskiwalne (skasowane) | Wyświetlaj pliki odzyskiwalne
Obecne | Wyświetlaj obecne (nieskasowane) pliki
Nadpisane, nierozpoznane | Wyświetlaj pliki nadpisane bądź nierozpoznane
Prawdopodob. nadpisane | Wyświetlaj pliki prawdopodobnie nadpisane
NTFS zaszyfrowane (EFS) | Wyświetlaj pliki zaszyfrowane NTFS
NTFS skompresowane | Wyświetlaj pliki skompresowane NTFS
NTFS metapliki | Wyświetlaj metapliki NTFS
- | -
Auto refresh | Odświeżaj automatycznie listę plików (aktualizuj) podczas zmian filtrów


15-AdvancedSearchWindow

Okno zaawansowanego wyszukiwania

SEKCJA | OPIS
Maska pliku (ów) | Maski plików do przeszukiwań
Znajdź dane | Ustaw dane do wyszukiwania i ich typ (ASCII/UNICODE/HEX)
Rozmiar pliku | Ustaw parametry rozmiarowe pliku
Atrybuty | Atrybuty poszukiwanych plików
Data | Data poszukiwanych plików


16-FoldersWindow

Okno konfiguracji folderów

StrongRecovery wymaga paru dodatkowych folderów do przechowywania ustawień konfiguracyjnych oraz zasobów tymczasowych (zrzuconych bądź otwieranych poprzez powłokę Windows). Model ten chroni przed nadpisaniem danych (na dysku gdzie mają być odzyskane). Tak czy inaczej twój bieżący dysk systemowy jest silnie narażony na różne sytuacje nadpisania (stronicowanie, tworzenie nowych plików, tworzenie plików tymczasowych, tworzenie plików przez przeglądarkę internetową). Wszystkie te sytuacje mogą przyczynić się do nadpisania twoich straconych danych. Zaleca się zamknąć bieżący system w takim wypadu, uruchomić inny i próbować wtedy odzyskiwać dane.


21-DemoVersion

Wersja demo

Oprogramowanie StrongRecovery jest rozpowszechniane jako wersja DEMO, oznacza to, że część funkcjonalności jest zablokowana. Wszystkie funkcje są dostępne po zakupie wersji pełnej (licencji).

Ograniczenia wersji DEMO:

  • Zapisywanie plików jest zablokowane
  • Otwieranie plików jest zablokowane
  • Szybkie przywracanie partycji jest zablokowane


22-Order

Zamów StrongRecovery

Dlaczego warto kupić oprogramowanie StrongRecovery?
  • Użytkownicy, którzy zakupili pełną wersję są uprzywilejowani do darmowych uaktualnień (free updates)
  • StrongRecovery jest nowym oprogramowaniem z nowoczesnymi cechami
  • Odzyskiwanie danych jest szybkie i proste
  • Możesz rozwinąć swoją firmę dzięki szybszemu odzyskiwaniu danych
  • Możliwość uzyskania wsparcia w specyficznej sytuacji (odzyskiwanie specjalnego formatu)
  • Większe bezpieczeństwo danych w przyszłości

StrongRecovery jest dostępne w wielu odmianach. Sprzedaż jest realizowana poprzez bezpieczne połączenie, sprawdź ofertę:


23-Updates

Aktualizacje StrongRecovery (updates)
Wstecz

Użytkownik, który zakupił pełną wersję StrongRecovery jest uprzywilejowany do otrzymywania darmowych uaktualnień, oznacza to, że użytkownik, który kupił np. wersję 2.xx będzie otrzymywał nowsze wersje (2.xx., 3.xx, x.xx).

Wstecz


Credits

Podziękowania

Bartosz Wojcik - beta testing, wsparcie i zabezpieczenie programu (http://www.pelock.com).


F.A.Q

F.A.Q (Najczęściej zadawane pytania)

Obecnie nie ma żadnych pytań w tej rubryce. Masz jakieś pytania? Napisz: support@strongrecovery.com.